?

Log in

No account? Create an account
Rage, What? No!

[Geek] Ah, Linux...

I. Hate. Modems.

So, after Antony had picked up all the computer parts he needed to build himself a low-cost Linux box on Saturday, he discovered that he didn't have a netinst image for Debian Sarge. So we downloaded that and burned it on my Powerbook before I dropped him at the efficiency for the night.

Only after I left did he discover that a) he had neglected to get IDE cables, and b) the used monitor he bought lacked a power cord. So this morning, he ran by Radio Shack to get IDE cables, and I brought him a power cord. Begin install process. Sarge installed fine, but we couldn't get the modem to dial... which means we couldn't get the last packages. After a bit of poking around, I realized that we didn't have the right driver. Hrm.

He ran off to meet with his recruiter, I came back here to do some things (including download Knoppix for Antony). We wandered around Fremont for a while -- saw the Fremont Market, had lunch at Roxy's, etc. -- and then we came back and burned the Knoppix CD. Knoppix, alas, didn't seem to have the drivers /either/.

So we came back to my place, found drivers -- which proved to be commercial, as it turns out the AOpen FM-56S and FM-56SV are two VERY DIFFERENT modems -- and took them back to his computer. Which, unfortunately, now refused to read CDs. Knoppix wouldn't even mount the Knoppix CD, now that it had been installed to HD. So we wiped Knoppix, put Sarge back on, and tried to install the drivers off of the CD I had burned.

Only to discover the drivers we had fought so long and hard to obtain... did not work on Linux 2.6.

I have never before been so glad that I converted to Mac as I was in that moment of sheer, blind frustration.

In the end, we gave up; it was getting on towards midnight, so we hooked up my Powerbook (which we'd finally thought to bring along this last time) and let him use my Speakeasy dialup to catch up on his e-mail and get the bus schedule.

He's going to go find some nice, sane modem tomorrow. And I am going to sleep.

Comments

I have a 3Com installed in my machine. It's great, except that it self-installs as ttyS4. Yes, that's right, 4. COM5: for you DOS-heads out there. Linux doesn't come with a lot of easy-to-use programs for setting up a dialup connection that include any references to anything higher than ttyS3. I eventually had to make a link at /dev/modem that pointed to it.

Why, oh, why is the syntax for "ln" backwards?

I finally got it working, but, well... the system has a startup script *somewhere* that assigns /dev/modem to something else, so every reboot erased my link. I wrote a script myself to rebuild the link every time, and put a call to it in my .login script. Finally it worked consistently.